Server Status

Crossplay Matchmaking Issues.
Incident Report for LEGO 2K Drive Status Page
Resolved
The game is now fully operational.
Posted Oct 14, 2023 - 06:35 UTC
Update
Crossplay Matchmaking is operational, we will continue monitoring the game.
Posted Oct 13, 2023 - 07:39 UTC
Update
We are monitoring Matchmaking issues on Cross-Play
Posted Oct 12, 2023 - 05:00 UTC
Update
A fix has been implemented, and we will continue monitoring the game.
Posted Oct 12, 2023 - 02:55 UTC
Update
We are monitoring Matchmaking issues on Cross-Play
Posted Oct 11, 2023 - 22:44 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 11, 2023 - 22:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2023 - 22:23 UTC
Investigating
We are experiencing intermittent issues with Crossplay Matchmaking. We are currently investigating this issue.
Posted Oct 09, 2023 - 19:54 UTC
This incident affected: Platforms (Nintendo, Epic Games, Steam, Playstation Network, Xbox Live) and Game Modes (Match Making).